Encaminamiento Estático

Este Laboratorio consiste en una simple configuración de encaminamiento estático entre tres routers y tres puestos. El routing estático no es el utilizado más comúnmente, puesto que es mucho mas versátil el encaminamiento dinámico. No obstante el encaminamiento estático es una práctica interesante.

El siguiente esquema representa los routers, las conexiones y las diferentes direcciones ip asignadas arbitrariamente, pudiendo ser utilizada cualquier otra dirección ip que deseemos respetando las diferentes subredes. En la figura se puede ver la topología

Empezaremos configurando los routers y después los pc’s explicando los comandos utilizados para el encaminamiento estático.

Se han elegido los routers 1721 porque son de los que disponemos en el laboratorio.

Router 1:

Por la interfaz serial 0 la cual se comunica con el router 2 se ha establecido la subred 192.168.0.X y la interfaz Ethernet 192.168.1.X

Configuramos las interfaces

Router> enable Router
Router# configure terminal
Router(config)# interface serial 0
Router(config-if)# ip address 192.168.0.1 255.255.255.0
Router(config-if)# clock rate 64000
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface ethernet 0
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
Router#

Ya tenemos nuestro router1 configurado con sus respectivas direcciones. Procederemos de la misma manera para todos lo routers teniendo en cuenta que cada conexion serial posee un DCE y por lo tanto hay que establecer el comando “clock rate” para el lado que lo sea, Yo he elegido el serial 0 del router 1 y el serial 1 del router 2, en el serial 0 del router 2 no habría que establecer el “clock rate” y en el router 3 tampoco.

Como ejemplo pondre como configurar el PC1

C:>ipconfig /ip 192.168.1.2 255.255.255.0
C:>ipconfig /dg 192.168.1.1

De la misma manera configuraremos los tres pc’s con sus respectivas ip’s y puertas de enlace.

Pasamos al tema central, el encaminamiento estático.

Tal y como se ha configurado el router y el pc solo es capaz de comunicarse con las redes adyacentes, es decir, por ejemplo el router 1 conoce la red de su conexion con el pc (192.168.1.0) y la red que le une con el router 2 (192.168.0.0) pero las otras redes como la 10.10.10.0, la 172.16.1.0 y la 172.16.0.0 las desconoce y no sabe como hacer para enrutar el tráfico que le puedan enviar con esos destinos,

Este tipo de encaminamiento al ser estático debemos conocer la topología de la red y las direcciones de las subredes por lo tanto debemos hacer uso de las rutas estáticas, es decir el comando clave para esta práctica es el comando:

ip route [subred] [mascara] [interfaz de acceso]

Para el router 1,si deseamos que se puedan comunicar el pc de la subred 10.10.10.0

Router#configure terminal
Router(config)#ip route 10.10.10.0 255.255.255.0 192.168.0.2

Si deseamos que se pueda comunicar con el resto de redes de este escenario debemos hacer una entrada para el resto de redes no adyacentes los comandos serían los siguientes:

Router(config)# ip route 10.10.10.0 255.255.255.0 192.168.0.2
Router(config)# ip route 172.16.0.0 255.255.255.0 192.168.0.2
Router(config)# ip route 172.16.1.0 255.255.255.0 192.168.0.2

Recordar que si queremos comunicarnos con el ordenador de la direccion 172.16.1.2 desde el router o el pc del router 1 los demás routers también deben tener las rutas, en este caso estáticas aunque también pueden ser dinámicas.

Las configuraciones de las rutas son:
Router 2:

Router(config)# ip route 192.168.1.0 255.255.255.0 192.168.0.1
Router(config)# ip route 172.16.1.0 255.255.255.0 172.16.0.2

Router 3:

Router(config)# ip route 192.168.0.0 255.255.255.0 172.16.0.2
Router(config)# ip route 192.168.1.0 255.255.255.0 172.16.0.2

Bueno una vez configurado los routers y los equipos solo falta testear la red haciendo ping desde los equipos y los routers para ver que se pueden comunicar entre ellos.

Espero que os haya gustado y que os sirva de ayuda

Alfredo

Powered by Qumana

~ por alfvizca en abril 9, 2007.

Una respuesta to “Encaminamiento Estático”

  1. Excelente y didáctica explicación, muchas gracias…

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: