Reflexión propia

•mayo 31, 2007 • Dejar un comentario

Como todos sabéis este blog fue creado por Manuel para guardar las configuraciones a lo largo del curso.

Según palabras suyas “hago las cosas porque me gusta hacerlo, con el fin de tenerlo para mi mismo y sin esperar nada de nadie”. Luego lo comentó y nos unimos varios a la causa, Pablo, Jose y yo. ¿Cual es la causa? crear configuraciones certeras de temas vistos en clase, que aparte de enriquecernos nos ayudaría a aprobar Redes de Área Local a todos.

Digo a todos, porque somos muchos más en clase y que decir tiene que la voz se ha corrido y todo el mundo conoce este blog, (y más gente que no tiene nada que ver con nosotros). Yo opino como él, pero hago un añadido, “Dar y Recibir”. Pongo un ejemplo: Todo el mundo hoy en día usa clientes de p2p de diferentes protocolos y redes tipo emule, bittorrent, Ares, … y aunque sus políticas de funcionamiento no sean exactamente iguales todas funcionan mediante la misma premisa “Dar para poder Recibir”.

¿Por que pongo todo este rollo?, porque pienso que al igual que más compañeros de nuestra clase se han beneficiado de este blog, todos ellos pueden y deben contribuir a hacer manuales de configuración y aportar detalles de comandos y archivos útiles para todos nosotros. Por eso os animo a que os pongáis en contacto con nosotros y poder redactar y subir posts con otras configuraciones y manuales que serán de gran interés para todos.

A mi personalmente, me ha dado tiempo a redactar algunos manuales y configuraciones aunque por supuesto he hecho muchas más pero no me ha dado tiempo a escribir y subir.

Creo firmemente en “Dar para Recibir” (No penséis mal ;-)) porque es la única manera de que algo funcione correctamente y que un sistema sea sostenible. Todos debemos contribuir a la causa común.

Un saludo a todos, me voy a poner a seguir a hacer soluciones porque como sabéis en el examen parcial que hubo el día 30 suspendí.

Anuncios

Nuevo foro de Dudas

•mayo 28, 2007 • 6 comentarios

He habilitado un foro de dudas para la asignatura, y así no mezclar los tutoriales de este blog con las dudas que puedan surgir acerca de los mismas. Si os parece bien.

La direccion es dudasral.wordpress.com. Supongo que no tendréis problemas, si no avisadme.

DHCP en Router Cisco

•mayo 28, 2007 • 14 comentarios

Como hacer un Servidor dhcp en router cisco.

La topología seria un router 1721 y un swich.

En el switch no hace falta que modifiquemos ningun tipo de configuracion salvo que necesitemos crear vlan o algo asi, pero con la configuración por defecto es suficiente.

El Router deberá tener la siguiente configuración:

Para la interfaz ethernet:

Router#configure terminal
Router(config)#interface fastethernet 0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Para configurar dhcp:

Router(config)#ip dhcp excluded-address 192.168.1.1
Router(config)#ip dhcp pool nombre
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1

Con esta configuración cualquier pc conectado al switch debería tomar direcciones dhcp

Alfredo

Powered by Qumana

Encaminamiento Dinámico (RIP)

•mayo 27, 2007 • 5 comentarios

Nos basaremos en el escenario del encaminamiento estático, la configuración es la misma para los routers y para los equipos.

Ahora nos meteremos directamente en el encaminamiento dinámico. Este tipo de encaminamiento es más útil debido a que los dispositivos aprenden las rutas dinámicamente y si la topología cambia, no es necesario que el administrador cambie la configuración.

Bueno pues para hacer que los routers actualicen e intercambien ellos solos las redes que tienen adyacentes y las que conocen lo debemos hacer con el siguiente comando:

#configure terminal

Router 1

Router>enable
Router#configure terminal
Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.0.0

Router 2

Router>enable
Router#configure terminal
Router(config)#router rip
Router(config-router)#network 192.168.0.0
Router(config-router)#network 10.10.10.0
Router(config-router)#network 172.16.0.0

Router 3

Router>enable
Router#configure terminal
Router(config)#router rip
Router(config-router)#network 172.16.0.0

Atención el router 3 solo lleva una red ya que esta dirección engloba tanto la 1.0, como la 0.0. Tener cuidado con esto ya que os puede dar problemas. Solución: o cambiáis la dirección de red de los serial a 172.16.2.0 por ejemplo o configuráis rip v2 que soporta mascaras variables. El comando sería para activarlo:

Router(config-router)#version 2

Todos los demás comandos iguales, incluso en rip v1 la configuración de ejemplo funciona.

Algunos comandos útiles:

Para ver que protocolo de encaminamiento estamos usando:

Router#show ip protocols

Para ver la tabla de encaminamiento:

Router#show ip route

Nota final, algunos routers no tienen activada el routing dinámico por lo que hay que activarlo con el comando, (no estoy seguro por favor que alguien lo ratifique ya que en el bosson no he encontrado el comando):

Router(config)#ip routing

Espero que sea de utilidad.

Powered by Qumana

Copiar Cisco IOS y Configuración a TFTP

•mayo 27, 2007 • 7 comentarios

Lo primero que deberemos hacer es montar un servidor TFTP, tal como se indica en el post anterior.

Una vez que tengamos configurado nuestro server en un equipo, tenemos que configurar la tarjeta ethernet de éste y del router que vayamos a salvar los datos. Es tan sencillo como configurar la tarjeta de red del equipo en la misma que tenga configurado nuestro router. Los pasos sería:

En el router

  1. router> enable
  2. router# configure terminal
  3. router(config)# interface fastethernet 0
  4. router(config-if)# ip address 192.168.1.1 255.255.255.0
  5. router(config-if)# no shutdown
  6. router(config-if)# exit

En el equipo (Ubuntu)

  1. # ifconfig eth0 192.168.1.2 netmask 255.255.255.0
  2. # ifconfig eth0 up

Ya tendriamos configurado las interfaces y sólo habría que conectarlas mediante un cable. Ya esta todo listo para empezar a copia.

Copiar Cisco IOS

Para conocer la versión del Cisco IOS, que necesitaremos saber para poder copiarlo, necesitamos ejecutar el siguiente comando:

router# show version

Entre otros datos aparecerá la versión de la imagen que tiene el router.

Para guardar el Cisco IOS debemos seguir los siguientes pasos:

  1. router# copy flash:nombre_imagen_ios tftp
  2. Remote host []? ip_del_servidor_tftp
  3. Name of configuration file to write [nombre_imagen]? pulsar enter

Y a continuación procederá con la copia de la imagen.

Copiar Ficheros de configuración (startup-config o running-config)

Es igual que copiar el IOS, el único comando que cambia es el primer.

  1. router# copy startup-config tftp
  2. Remote host []? ip_del_servidor_tftp
  3. Name of configuration file to write [nombre_imagen]? pulsar enter

Y ya tendriamos copiado la configuración del router que tanto nos ha llevado configurar ;P.

MTB

Servidor TFTP

•mayo 26, 2007 • 3 comentarios

TFTP son las siglas de Trivial File Transfer Protocol (Protocolo de transferencia de archivos trivial). Es similar al FTP, pero sin autentificación. La conexión se realiza mediante UDP por el puerto 69. Lo utilizaremos para salvar configuraciones de los routers o switchs, o las imágenes del sistema operativo de estos.

Servidor

En primer lugar instalaremos el servidor en una máquina Ubuntu, para ello ejecutaremos en consola el siguiente comando:

# aptitude install tftpd-hpa

Una vez instalado el servidor procedemos a configurar un fichero, para ello lo abriremos con un editor, el que mas os guste, aunque en mi caso utilizaré VIM.

# vim /etc/default/tftpd-hpa

Una vez abierto pondremos las dos opciones con los valores que indico a continuación.

RUN_DAEMON=”yes”

OPTIONS=”-l -c -s /srv/tftp”

Las opciones indican lo siguiente:

-l : es para que el servidor se ejecute como daemon.

-c : está opción nos permitirá poder escribir/enviar datos al servidor tftp.

-s <directorio>: está opción indica el directorio que utilizaremos para bajarnos y subir cosas. En mi caso he utilizado el directorio /srv/tftp, que previamente he creado, pero se puede optar por cualquier otro. Hay que tener en cuenta que tiene que tener permiso para cualquiera que acceda, por lo que hay que asignarle correctamente los permisos.

Una vez modificado dicho fichero, procedemos a lanzar el servidor, para ello ejecutamos:

# /etc/init.d/tftpd-hpa start

Y ya tendriamos listo el servidor.

Cliente

Para conectarnos al servidor debemos instalar un cliente, como siempre utilizaremos la herramienta aptitude, esta vez será:

# aptitude install tftp-hpa

Una vez conectado procedemos ha realizar la conexión con el servidor, suponiendo que el servidor tiene la IP 192.168.1.100, realizaremos la conexión de la siguiente forma:

# tftp 192.168.1.100

Ahora nos aparecerá un prompt del tftp, en el cual podremos hacer put y get para enviar y recibir ficheros respectivamente. Para consultar los comandos que podemos ejecutar, utilizaremos el comando ? .

MTB

Instalar una tarjeta NIC VIA en Solaris (Tarjeta interna)

•mayo 25, 2007 • 2 comentarios

Actualmente, en los ordenadores del laboratorio se encuentran instaladas ambas. Sin embargo, en vistas a las modificaciones y/o formateo que puede hacerse en el mismo, explicaremos cómo se realiza este paso.

1.Activamos la otra tarjeta de red, para poder acceder a internet. Para ello utilizamos el comando:

ifconfig rtls0 plumb

A continuación, le damos ip. Utilizamos el servidor de DHCP que disponemos en la universidad para ello. Así no nos preocuparemos de darle luego DNS.

ifconfig rtls0 dhcp

En caso contrario, procedemos con los comandos siguientes:

ifconfig rtls0 X.X.X.X netmask Y.Y.Y.Y

route add default gw X.X.X.X (Es posible que el sistema operativo nos indique que sobra algún parámetro, será default o gw, ahora desconozco cual de ellos era)

Editamos el fichero /etc/resolv.conf, donde colocaremos la ip del servidor de nombres de dominio al estilo que se indica

nameserver 158.49.17.21

Editamos etc/nsswitch.conf, y en las líneas en que aparece hosts,ipnodes y networks, añadimos al final “dns”. Finalmente, habilitamos las DNS con la instrucción:

svcadm enable dns/server

2. Localizamos el navegador web, ya que necesitamos acceder a una pagina para descargarnos el fichero driver. Para ello realizamos una búsqueda:

find / -name mozilla

Seguramente os lo encuentre en /usr/sfw/bin/mozilla, exportaremos dicho path de la forma que sigue, para luego poder ejecutarlo sin tener que nombrarlo por todo el path:

export PATH=$PATH:/usr/sfw/bin/mozilla

mozilla &

El signo & sirve para poder mantener el terminal en segundo plano, mientras se ejecuta el Mozilla.

3. Accedemos por Archivo->Abrir dirección que adjuntamos para descargamos el archivo de la web. Este archivo viene comprimido en tar-gz.

Archivo a descargar

4. Una vez descargado, cerramos el navegador. Y en el terminal, nos dirigimos a la carpeta donde hemos guardado el archivo. Una vez allí, realizamos la descompresión del archivo:

gunzip vfe-1.1.0.tar.gz

tar xvf vfe-1.1.0.tar

Entonces habremos creado una carpeta en la carpeta actual con el nombre vfe-1.1.0

5. Accedemos a dicha carpeta mediante el uso de la instrucción:

cd vfe-1.1.0

6. Borraremos los archivos con extensión obj (objetos de compilación) y el Makefile. Para ello podemos utilizar la instrucción:

rm obj Makefile

7. Creamos los nuevos enlaces de ficheros. Como los ordenadores de la sala son AMD 64 bit, aparece en estos enlaces dicha nomenclatura. Hemos de suponer que para el resto habrá ficheros de la misma manera.

ln -s Makefile.amd64_gcc Makefile

ln -s amd64 obj

8. Inicializamos ahora la instalación. Para ello, ejecutaremos la orden siguiente:

/usr/ccs/bin/make install

9. Cuando concluya este paso, y sin salirnos de la carpeta donde se encuentran los ficheros que venían en el archivo comprimido, ejecutamos el script siguiente:

./adddrv.sh

10. A la conclusión del mismo, conectamos la tarjeta. Este proceso no debe dar ningún error (comprobado), en caso contrario, repitase el proceso desde el punto 6. Probamos la conexión de la tarjeta. PAra darle IP y demás seguir lo pasos indicados en el punto 1 con la tarjeta externa rtls0.

ifconfig vfe0 plumb -> Conectar la tarjeta

ifconfig -a ->Ver si la ha reconocido

11. Finalmente, procedemos a crear una serie de archivos, a fin que el montaje de las tarjetas sea automático,e incluso, que en el inicio de las mismas, estas ya tomen ip por DHCP si le es posible. Para ello tenemos que hacer lo siguiente:

touch /etc/hostname.vfe0

touch /etc/hostname.rtls0

touch /etc/dhcp.vfe0

touch /etc/dhc.rtls0

Espero que os sirva. Saludos.